A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream.
Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.
{
"cna_assigner": "Google",
"cwe_ids": [
"CWE-252",
"CWE-787"
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/111xxx/CVE-2026-111497.json"
}{
"extracted_events": [
{
"range": [
{
"introduced": "1.0.3"
},
{
"fixed": "1.0.10"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"range": [
{
"introduced": "1.1.0"
},
{
"fixed": "1.1.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"range": [
{
"introduced": "1.2.0"
},
{
"fixed": "1.2.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"original_tag": "v1.2.1",
"range": [
{
"fixed": "db24a98aed38a16de78cc05ca15cdd8dc2a0d92d"
}
],
"source": "REFERENCES_TAG"
},
{
"original_tag": "v1.1.1",
"range": [
{
"fixed": "db0631dfea829194206d269bc7b25d0908cdb97d"
}
],
"source": "REFERENCES_TAG"
},
{
"original_tag": "v1.0.10",
"range": [
{
"fixed": "3646606894cd8b8c75d79a569b6c95a33c699d63"
}
],
"source": "REFERENCES_TAG"
}
]
}